On Thu, 2016-03-03 at 14:45 -0800, Dan Williams wrote: > On Wed, Mar 2, 2016 at 2:50 PM, Toshi Kani <toshi.kani@xxxxxxx> wrote: : > > > > diff --git a/kernel/resource.c b/kernel/resource.c > > index effb6ee..b1a3394 100644 > > --- a/kernel/resource.c > > +++ b/kernel/resource.c > > @@ -1449,6 +1449,75 @@ void __devm_release_region(struct device *dev, > > struct resource *parent, > > EXPORT_SYMBOL(__devm_release_region); > > > > /* > > + * Remove function for devm_insert_resource() and > > devm_remove_resource(). > > + */ > > +static void devm_resource_remove(struct device *dev, void *ptr) > > +{ > > + struct resource **r = ptr; > > + > > + remove_resource(*r); > > +} > > + > > Maybe call this __devm_remove_resource? I think this makes it clearer > that it is a private helper function. I was initially confused about > the difference between devm_resource_remove and devm_remove_resource. Will do. I followed the naming convention of devm_resource_release() in the same file, but I agree that this is confusing. Thanks, -Toshi -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html