On Wed, Feb 04, 2015 at 09:48:05AM +0000, Hanjun Guo wrote: > On 2015年02月04日 04:09, Catalin Marinas wrote: > > diff --git a/arch/arm64/include/asm/acpi.h b/arch/arm64/include/asm/acpi.h > > index ea4d2b35c57b..4fafd62b1b86 100644 > > --- a/arch/arm64/include/asm/acpi.h > > +++ b/arch/arm64/include/asm/acpi.h > > @@ -49,33 +49,12 @@ static inline void enable_acpi(void) > > acpi_noirq = 0; > > } > > > > -/* MPIDR value provided in GICC structure is 64 bits, but the > > - * existing phys_id (CPU hardware ID) using in acpi processor > > - * driver is 32-bit, to conform to the same datatype we need > > - * to repack the GICC structure MPIDR. > > - * > > - * bits other than following 32 bits are defined as 0, so it > > - * will be no information lost after repacked. > > - * > > - * Bits [0:7] Aff0; > > - * Bits [8:15] Aff1; > > - * Bits [16:23] Aff2; > > - * Bits [32:39] Aff3; > > - */ > > -static inline u32 pack_mpidr(u64 mpidr) > > -{ > > - return (u32) ((mpidr & 0xff00000000) >> 8) | mpidr; > > -} > > - > > /* > > * The ACPI processor driver for ACPI core code needs this macro > > * to find out this cpu was already mapped (mapping from CPU hardware > > * ID to CPU logical ID) or not. > > - * > > - * cpu_logical_map(cpu) is the mapping of MPIDR and the logical cpu, > > - * and MPIDR is the cpu hardware ID we needed to pack. > > */ > > -#define cpu_physical_id(cpu) pack_mpidr(cpu_logical_map(cpu)) > > +#define cpu_physical_id(cpu) cpu_logical_map(cpu) > > > > /* > > * It's used from ACPI core in kdump to boot UP system with SMP kernel, > > diff --git a/arch/arm64/include/asm/smp_plat.h b/arch/arm64/include/asm/smp_plat.h > > index 59e282311b58..a492276e008d 100644 > > --- a/arch/arm64/include/asm/smp_plat.h > > +++ b/arch/arm64/include/asm/smp_plat.h > > @@ -40,4 +40,6 @@ static inline u32 mpidr_hash_size(void) > > extern u64 __cpu_logical_map[NR_CPUS]; > > #define cpu_logical_map(cpu) __cpu_logical_map[cpu] > > > > +typedef u64 cpuid_t; > > I think cpuid_t is a little confused because people may recognize > it as cpu logical id, its original meaning is the physical cpu ID, > so how about: > > typedef u64 phys_id_t; ? I would keep "cpu" somewhere in the name as "phys" is too generic, maybe phys_cpuid_t. -- Catalin -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html