On Fri, Oct 03, 2014 at 04:03:51AM +0200, Rafael J. Wysocki wrote: > On Thursday, October 02, 2014 04:36:54 PM Mika Westerberg wrote: > > On Thu, Oct 02, 2014 at 02:46:30PM +0200, Arnd Bergmann wrote: > > > On Thursday 02 October 2014 15:15:08 Mika Westerberg wrote: > > [cut] > > > > > Putting everything to a single package results this: > > > > Package () { "pwms", Package () {"led-red", ^PWM0, 0, 10, "led-green", ^PWM0, 1, 10 }} > > > > But I think the below looks better: > > I agree. > > > Package () { "pwms", Package () {^PWM0, 0, 10, ^PWM0, 1, 10 }} > > Package () { "pwm-names", Package () {"led-red", "led-green"}} > > > > and it is trivial to match with the corresponding DT fragment. > > > > > } > > > > > > vs. > > > > > > pwm-slave { > > > pwms = <&pwm0 0 10>, <&pwm1 1 20>; > > > pwm-names = "led-red", "led-green"; > > > }; > > > > > > > I don't have strong feelings which way it should be. The current > > implementation limits references so that you can have only integer > > arguments, like {ref0, int, int, ref1, int} but if people think it is > > better to allow strings there as well, it can be changed. > > > > I would like to get comments from Darren and Rafael about this, though. > > In my opinion there needs to be a "canonical" representation of the > binding that people always can expect to work. It seems reasonable to > use the one exactly matching the DT representation for that. > > In addition to that we can add other representations that the code will > also parse correctly as alternatives. In the future. OK, so if no objections and Arnd promised not to complain too loudly, I would like to keep this as is for now. -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html