Hi Rafael, Thanks for reminder, will fix it in next version. Cheers! Gerry On 2014/2/18 9:07, Rafael J. Wysocki wrote: > On Monday, February 17, 2014 01:02:50 PM Jiang Liu wrote: >> Use public function acpi_evaluate_pad() to replace open-coded > > I suppose you mean acpi_evaluate_ost()? And in the other patches > in this series too? > >> version of evaluating ACPI _OST method. >> >> Signed-off-by: Jiang Liu <jiang.liu@xxxxxxxxxxxxxxx> >> --- >> drivers/acpi/acpi_pad.c | 24 +++++------------------- >> 1 file changed, 5 insertions(+), 19 deletions(-) >> >> diff --git a/drivers/acpi/acpi_pad.c b/drivers/acpi/acpi_pad.c >> index 1e3ce76..86b4e11 100644 >> --- a/drivers/acpi/acpi_pad.c >> +++ b/drivers/acpi/acpi_pad.c >> @@ -408,28 +408,14 @@ static int acpi_pad_pur(acpi_handle handle) >> return num; >> } >> >> -/* Notify firmware how many CPUs are idle */ >> -static void acpi_pad_ost(acpi_handle handle, int stat, >> - uint32_t idle_cpus) >> -{ >> - union acpi_object params[3] = { >> - {.type = ACPI_TYPE_INTEGER,}, >> - {.type = ACPI_TYPE_INTEGER,}, >> - {.type = ACPI_TYPE_BUFFER,}, >> - }; >> - struct acpi_object_list arg_list = {3, params}; >> - >> - params[0].integer.value = ACPI_PROCESSOR_AGGREGATOR_NOTIFY; >> - params[1].integer.value = stat; >> - params[2].buffer.length = 4; >> - params[2].buffer.pointer = (void *)&idle_cpus; >> - acpi_evaluate_object(handle, "_OST", &arg_list, NULL); >> -} >> - >> static void acpi_pad_handle_notify(acpi_handle handle) >> { >> int num_cpus; >> uint32_t idle_cpus; >> + struct acpi_buffer param = { >> + .length = 4, >> + .pointer = (void *)&idle_cpus, >> + }; >> >> mutex_lock(&isolated_cpus_lock); >> num_cpus = acpi_pad_pur(handle); >> @@ -439,7 +425,7 @@ static void acpi_pad_handle_notify(acpi_handle handle) >> } >> acpi_pad_idle_cpus(num_cpus); >> idle_cpus = acpi_pad_idle_cpus_num(); >> - acpi_pad_ost(handle, 0, idle_cpus); >> + acpi_evaluate_ost(handle, ACPI_PROCESSOR_AGGREGATOR_NOTIFY, 0, ¶m); >> mutex_unlock(&isolated_cpus_lock); >> } >> >> > -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html