On Fri, 2013-05-03 at 21:31 +0200, Rafael J. Wysocki wrote: > On Friday, May 03, 2013 12:27:54 PM Toshi Kani wrote: > > On Fri, 2013-05-03 at 14:05 +0200, Rafael J. Wysocki wrote: > > > On Thursday, May 02, 2013 05:20:12 PM Toshi Kani wrote: : > > One minor comment. > > > > +static __cpuinit int __acpi_processor_start(struct acpi_device *device) > > > { > > > - struct acpi_device *device = per_cpu(processor_device_array, > > pr->id); > > > + struct acpi_processor *pr = acpi_driver_data(device); > > > + acpi_status status; > > > int result = 0; > > > > > > + if (!pr) > > > + return -ENODEV; > > > + > > > + if (pr->flags.need_hotplug_init) > > > + return 0; > > > + > > > > I felt the name of "need_hotplug_init" is a bit misleading since the > > func actually skips when the need-flag is set. It may be nice to rename > > it to defer_online_init, offline or something like that. > > I just wanted to avoid making too many non-essential changes in one patch. > We can change the name of that field at any time later. Sounds good to me. Thanks, -Toshi -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html