On Tue, Jan 22, 2013 at 3:19 PM, Yinghai Lu <yinghai@xxxxxxxxxx> wrote: > On Tue, Jan 22, 2013 at 2:09 PM, Rafael J. Wysocki <rjw@xxxxxxx> wrote: >> On Monday, January 21, 2013 01:20:41 PM Yinghai Lu wrote: >>> It includes >>> 1. preparing patches for pci root bus hotadd/hotremove support >>> 2. move root bus hotadd from acpiphp to pci_root.c >>> 3. add hot-remove support >>> 4. add acpi_hp_work to be shared with acpiphp and root-bus hotplug >>> 5. add match_driver to add pci device to device tree early but >>> not attach driver for hotplug path. >>> >>> based on pci/next + pm/acpi-scan >>> >>> could get from >>> git://git.kernel.org/pub/scm/linux/kernel/git/yinghai/linux-yinghai.git for-pci-root-bus-hotplug >>> >>> -v9: merges several patches together for easy review, requested by Rafael. >>> -v10: address comments from Rafael. >>> >>> Jiang Liu (2): >>> PCI: Fix a device reference count leakage issue in pci_dev_present() >>> PCI: make PCI device create/destroy logic symmetric >>> >>> Tang Chen (1): >>> PCI, ACPI: debug print for installation of acpi root bridge's >>> notifier >>> >>> Yinghai Lu (8): >>> PCI, acpiphp: Add is_hotplug_bridge detection >>> PCI: Add root bus children dev's res to fail list >>> PCI: Set dev_node early for pci_dev >>> PCI, ACPI, acpiphp: Rename alloc_acpiphp_hp_work() to alloc_acpi_hp_work >>> PCI, acpiphp: Move and enhance hotplug support of pci host bridge >>> PCI, acpiphp: Don't bailout even no slots found yet. >>> PCI: Skip attaching driver in device_add() >>> PCI: Put pci dev to device tree as early as possible >> >> OK >> >> Please feel free to add >> >> Acked-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx> >> >> to all of the patches in this series I haven't acked already. I first pulled in "git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git acpi-scan" again (to pci/acpi-scan2), added your acks, Rafael, and put this series on a pci/yinghai-root-bus branch based on pci/acpi-scan2. I reworked some of the changelogs a bit, but I don't think I made any code changes except that in [10/11] I just inlined the pci_bus_attach_device() code rather than making a new function, since it's small, there's only one caller, and I didn't think we needed any more pci_* and pci_bus_* functions than we already have. Let me know if I messed anything up. Bjorn -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html