Re: [PATCH v2] ACPI: fix acpi_power_off lockdep splat

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Jul 04, 2011 at 12:28:23AM +0200, Rafael J. Wysocki wrote:
> On Monday, July 04, 2011, Rafael J. Wysocki wrote:
> > On Sunday, July 03, 2011, Rafael J. Wysocki wrote:
> > > On Sunday, July 03, 2011, Andrea Righi wrote:
> > > > Implement acpi_os_create_lock() as a C-preprocessor macro to suppress
> > > > lockdep false positive.
> > > > 
> > > > When lockdep is enabled the spin_lock_init macro stringifies it's
> > > > argument and uses that as a name for the lock in the debugging.
> > > > 
> > > > By executing spin_lock_init in a macro the key changes from "lock" for
> > > > all locks to the actual argument of acpi_os_create_lock()
> > > > ("&acpi_gbl_global_lock_pending_lock", "&acpi_gbl_gpe_lock" or
> > > > "&acpi_gbl_hardware_lock" for now).
> > > > 
> > > > This fixes:
> > > > https://bugzilla.kernel.org/show_bug.cgi?id=38152
> > > > 
> > > > ChangeLog (v1 -> v2):
> > > >  - avoid to call spin_lock_init multiple times on the same lock
> > > >  - rewrite patch description (thanks to Florian for providing a better
> > > >    description of the patch)
> > > > 
> > > > Reported-by: Borislav Petkov <bp@xxxxxxxxx>
> > > > CC: Florian Mickler <florian@xxxxxxxxxxx>
> > > > Signed-off-by: Andrea Righi <andrea@xxxxxxxxxxxxxxx>
> > > > ---
> > > >  drivers/acpi/osl.c      |    3 +--
> > > >  include/acpi/acpiosxf.h |   12 +++++++++++-
> > > >  2 files changed, 12 insertions(+), 3 deletions(-)
> > > > 
> > > > diff --git a/drivers/acpi/osl.c b/drivers/acpi/osl.c
> > > > index 52ca964..4c985d3 100644
> > > > --- a/drivers/acpi/osl.c
> > > > +++ b/drivers/acpi/osl.c
> > > > @@ -1336,14 +1336,13 @@ EXPORT_SYMBOL(acpi_resources_are_enforced);
> > > >   * Create and initialize a spinlock.
> > > >   */
> > > >  acpi_status
> > > > -acpi_os_create_lock(acpi_spinlock *out_handle)
> > > > +__acpi_os_create_lock(acpi_spinlock *out_handle)
> > > >  {
> > > 
> > > I would rename this to acpi_os_allocate_lock() or acpi_os_alloc_lock(),
> > > so that it doesn't suggest the lock is initialized by this function.
> > > 
> > > Hmm.  There's one more thing we need to take into account here.  Namely,
> > > include/acpi/acpiosxf.h is used by other OSes, so we shouldn't put
> > > Linux-specific stuff into it.
> > > 
> > > I'm not sure how to work around that at the moment.
> > 
> > OK, the patch below builds for me and seems to work even, although I haven't
> > tested it with lockdep on.
> 
> Below is a cleaned-up version, still untested with lockdep on.

Tested. Works fine for me.

Thanks!
-Andrea
--
To unsubscribe from this list: send the line "unsubscribe linux-acpi" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux IBM ACPI]     [Linux Power Management]     [Linux Kernel]     [Linux Laptop]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux