* Mike Travis <travis@xxxxxxx> wrote: > +++ linux/kernel/printk.c > @@ -162,46 +162,65 @@ void log_buf_kexec_setup(void) > } > #endif > > +static unsigned long __initdata new_log_buf_len; > static int __init log_buf_len_setup(char *str) > { Can you see the readability problem this new line introduces? > + char first_line[64], *first_nl; The value 64 looks arbitrary. Needs to be symbolized and explained. (That would also make the sizeof(first_line) usage more readable later on.) > + pr_info("log_buf_len: %d, first line: %s\n", > + log_buf_len, first_line); It's not just arbitrarily sized, but i dont see where it's guaranteed that it's a nil delimited string. > + pr_debug("bu: %d/%d (%d%%)\n", > + dest_idx, __LOG_BUF_LEN - dest_idx, > + (dest_idx * 100) / __LOG_BUF_LEN); What's that? Patch looks pretty ad-hoc. No comments whatsoever what the intention is either, so the reader has to go figure out the code. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html