On Tue, Nov 16, 2010 at 3:50 AM, Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote: > On Tue, 2010-11-16 at 08:53 +0800, Huang Ying wrote: >> +/** >> + * llist_del_all - delete all entries from lock-less list >> + * @head: the head of lock-less list to delete all entries >> + * >> + * If list is empty, return NULL, otherwise, delete all entries and >> + * return the pointer to the first entry. >> + */ >> +struct llist_node *llist_del_all(struct llist_head *head) >> +{ >> + return xchg(&head->first, NULL); >> +} >> +EXPORT_SYMBOL_GPL(llist_del_all); > > Its not del_all, since it returns the actual list. move or splice might > be better names. I don't think it's a "move", since the result isn't actually a list_head (it's by definition a "we remove all entries from the list, and then we can look at the list entries in private afterwards"). So the "delete" part _is_ important - before the op, we had an atomic list. After the op, we just have a bunch of entries (they may be a list, but they aren't a _lock-less_ list any more: they are literally just private entries now). So both "move" and "splice" imply at least to me that the target is equivalent to the source. And it really isn't. The target is something totally different. In fact, my original objection to this code was that there wasn't a good separation between "entries" and "lock-less head of list", and it used the same type for both - the way the regular list functions do. In the regular list implementation, each list entry really is a list head too, and you can have lists that don't even _have_ separate heads, but everything is a list entry (common in things like the dentry "siblings" list, where each dentry can be used as the "head" to that sibling list - all siblings are equal). Now, I don't know if "del_all" is necessarily the proper name, but I do think that it's important to make it clear that as far as the lock-lessness of the list is concerned, the operation really is about removing all entries, and it's not some kind of symmetric operation wrt src/dest like with normal lists. Linus -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html