(2010/08/17 12:22), Huang Ying wrote: > On Tue, 2010-08-17 at 10:14 +0800, Jin Dongming wrote: >>> I don't think it is necessary to change the header definition, and >>> seri_header is not a good name for me. >> Why I added this structure here is that I don't want to do following checking. >> For example, >> if (header_length != 0x0c) { >> ... >> } > > This can be: > > static int erst_check_table(struct acpi_table_erst *erst_tab) > { > - if (erst_tab->header_length != sizeof(struct acpi_table_erst)) > + if (erst_tab->header_length != > + (sizeof(struct acpi_table_erst) - sizeof(erst_tab->header))) > > like Yinghai has been done. > Yes. It looks good. And I am sorry I am unaware of Yinghai' patch. > Best Regards, > Huang Ying > > Best Regards, Jin Dongming > -- > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html > Please read the FAQ at http://www.tux.org/lkml/ > > -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html