On Friday 19 March 2010 12:49:20 Dan Carpenter wrote: > acpi_device_class can only be 19 characters and a NULL terminator. > > The current code has a buffer overflow in acpi_power_meter_add(): > strcpy(acpi_device_class(device), ACPI_POWER_METER_CLASS); Sounds as if it would be worth to add: CC: stable@xxxxxxxxxx ? Same for processor_aggregator. Thomas > > Signed-off-by: Dan Carpenter <error27@xxxxxxxxx> > --- > Feel free to change the name to anything you like. > > diff --git a/drivers/acpi/power_meter.c b/drivers/acpi/power_meter.c > index 834c5af..31baa1e 100644 > --- a/drivers/acpi/power_meter.c > +++ b/drivers/acpi/power_meter.c > @@ -34,7 +34,7 @@ > #define ACPI_POWER_METER_NAME "power_meter" > ACPI_MODULE_NAME(ACPI_POWER_METER_NAME); > #define ACPI_POWER_METER_DEVICE_NAME "Power Meter" > -#define ACPI_POWER_METER_CLASS "power_meter_resource" > +#define ACPI_POWER_METER_CLASS "pwr_meter_resource" > > #define NUM_SENSORS 17 > > -- -- To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html