Re: [PATCH] ACPI: re-name acpi_pm_ops to acpi_suspend_ops

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi!

> Pavel, Rafael,
> I re-named the acpi_pm_* ops to be acpi_suspend_* below.
> 
> I think also that main.c isn't the best name for this file,
> how about acpi_platform_suspend.c, or maybe just acpi_suspend.c?

sleep/main.c sounds quite sensible, but I guess acpi_suspend.c would
be okay, too.

> commit 2c6e33c366bff2f839df60d9235ff09143e28dd9
> Author: Len Brown <len.brown@xxxxxxxxx>
> Date:   Wed Apr 23 18:02:52 2008 -0400
> 
>     ACPI: re-name acpi_pm_ops to acpi_suspend_ops
>     
>     ... as they are platform_suspend_ops after all.
>     
>     cosmetic re-name only, no functional change.
>     
>     Signed-off-by: Len Brown <len.brown@xxxxxxxxx>
> 
> diff --git a/drivers/acpi/sleep/main.c b/drivers/acpi/sleep/main.c
> index 71183ee..c3b0cd8 100644
> --- a/drivers/acpi/sleep/main.c
> +++ b/drivers/acpi/sleep/main.c
> @@ -51,7 +51,7 @@ static int acpi_sleep_prepare(u32 acpi_state)
>  }
>  
>  #ifdef CONFIG_SUSPEND
> -static struct platform_suspend_ops acpi_pm_ops;
> +static struct platform_suspend_ops acpi_suspend_ops;
>  

ACK.

>  extern void do_suspend_lowlevel(void);
>  
> @@ -65,11 +65,11 @@ static u32 acpi_suspend_states[] = {
>  static int init_8259A_after_S1;
>  
>  /**
> - *	acpi_pm_begin - Set the target system sleep state to the state
> + *	acpi_suspend_begin - Set the target system sleep state to the state
>   *		associated with given @pm_state, if supported.
>   */
>  
> -static int acpi_pm_begin(suspend_state_t pm_state)
> +static int acpi_suspend_begin(suspend_state_t pm_state)

And yes, this means it is very good idea.
									Pavel

-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
--
To unsubscribe from this list: send the line "unsubscribe linux-acpi" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux IBM ACPI]     [Linux Power Management]     [Linux Kernel]     [Linux Laptop]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux