On Fri, Aug 30, 2024 at 07:58:09AM +0000, Tian, Kevin wrote: > > @@ -3103,7 +3103,8 @@ arm_smmu_domain_alloc_user(struct device *dev, > > u32 flags, > > const struct iommu_user_data *user_data) > > { > > struct arm_smmu_master *master = dev_iommu_priv_get(dev); > > - const u32 PAGING_FLAGS = IOMMU_HWPT_ALLOC_DIRTY_TRACKING; > > + const u32 PAGING_FLAGS = IOMMU_HWPT_ALLOC_DIRTY_TRACKING | > > + IOMMU_HWPT_ALLOC_NEST_PARENT; > > lowercase for variable name. Ah, but it is constant :) I have no idea if there is a style consensus here Thanks, Jason