Hi all, This patch series, generated using Coccinelle, aims to improve code readability and maintainability by replacing ternary operations with the min() and max() macros where applicable in the ACPI subsystem. The patches have been compiled and tested on an x86_64 system. Changes in v2: - fix: replace max() to umax() for unsigned integer Prabhakar Pujeri (2): ACPI: CPPC: Replace ternary operator with max() in cppc_find_dmi_mhz ACPI: PM: Use max() for clearer D3 state selection in acpi_dev_pm_get_state drivers/acpi/cppc_acpi.c | 2 +- drivers/acpi/device_pm.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) -- 2.45.2