On 6/29/2023 5:58 PM, Rafael J. Wysocki wrote: > On Fri, Jun 16, 2023 at 6:51 PM Michal Wilczynski > <michal.wilczynski@xxxxxxxxx> wrote: >> Currently logic for installing notifications from ACPI devices is >> implemented using notify callback in struct acpi_driver. Preparations >> are being made to replace acpi_driver with more generic struct >> platform_driver, which doesn't contain notify callback. Furthermore >> as of now handlers are being called indirectly through >> acpi_notify_device(), which decreases performance. >> >> Call acpi_dev_install_notify_handler() at the end of .add() callback. >> Call acpi_dev_remove_notify_handler() at the beginning of .remove() >> callback. Change arguments passed to the notify function to match with >> what's required by acpi_install_notify_handler(). Remove .notify >> callback initialization in acpi_driver. >> >> Suggested-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx> >> Signed-off-by: Michal Wilczynski <michal.wilczynski@xxxxxxxxx> >> --- >> drivers/acpi/acpi_video.c | 26 ++++++++++++++++++++++---- >> 1 file changed, 22 insertions(+), 4 deletions(-) >> >> diff --git a/drivers/acpi/acpi_video.c b/drivers/acpi/acpi_video.c >> index 62f4364e4460..60b7013d0009 100644 >> --- a/drivers/acpi/acpi_video.c >> +++ b/drivers/acpi/acpi_video.c >> @@ -77,7 +77,7 @@ static DEFINE_MUTEX(video_list_lock); >> static LIST_HEAD(video_bus_head); >> static int acpi_video_bus_add(struct acpi_device *device); >> static void acpi_video_bus_remove(struct acpi_device *device); >> -static void acpi_video_bus_notify(struct acpi_device *device, u32 event); >> +static void acpi_video_bus_notify(acpi_handle handle, u32 event, void *data); >> >> /* >> * Indices in the _BCL method response: the first two items are special, >> @@ -104,7 +104,6 @@ static struct acpi_driver acpi_video_bus = { >> .ops = { >> .add = acpi_video_bus_add, >> .remove = acpi_video_bus_remove, >> - .notify = acpi_video_bus_notify, >> }, >> }; >> >> @@ -1527,12 +1526,15 @@ static int acpi_video_bus_stop_devices(struct acpi_video_bus *video) >> acpi_osi_is_win8() ? 0 : 1); >> } >> >> -static void acpi_video_bus_notify(struct acpi_device *device, u32 event) >> +static void acpi_video_bus_notify(acpi_handle handle, u32 event, void *data) >> { >> - struct acpi_video_bus *video = acpi_driver_data(device); >> + struct acpi_device *device = data; >> + struct acpi_video_bus *video; >> struct input_dev *input; >> int keycode = 0; >> >> + video = acpi_driver_data(device); >> + >> if (!video || !video->input) >> return; >> >> @@ -2053,8 +2055,20 @@ static int acpi_video_bus_add(struct acpi_device *device) >> >> acpi_video_bus_add_notify_handler(video); >> >> + error = acpi_dev_install_notify_handler(device, >> + ACPI_DEVICE_NOTIFY, >> + acpi_video_bus_notify); >> + if (error) >> + goto err_remove_and_unregister_video; > This label name is a bit too long and the second half of it doesn't > really add any value IMV. err_remove would be sufficient. I've seen different patterns in the code, sometimes the label describe what failed, sometimes it describe what needs to be cleaned up. I don't really have a strong preference, just thought it might be useful to the reader. Will change as suggested. > >> + >> return 0; >> >> +err_remove_and_unregister_video: >> + mutex_lock(&video_list_lock); >> + list_del(&video->entry); >> + mutex_unlock(&video_list_lock); >> + acpi_video_bus_remove_notify_handler(video); >> + acpi_video_bus_unregister_backlight(video); >> err_put_video: >> acpi_video_bus_put_devices(video); >> kfree(video->attached_array); >> @@ -2075,6 +2089,10 @@ static void acpi_video_bus_remove(struct acpi_device *device) >> >> video = acpi_driver_data(device); >> >> + acpi_dev_remove_notify_handler(device, >> + ACPI_DEVICE_NOTIFY, >> + acpi_video_bus_notify); >> + >> mutex_lock(&video_list_lock); >> list_del(&video->entry); >> mutex_unlock(&video_list_lock); >> -- >> 2.41.0 >>