Hi, After a longer while this is a re-spin of the DSA migration to fwnode_/device_ API. It addresses all comments from the previous iteration - the details are summarized in the changelog section below. For reference, here is the discussion under v3. https://lore.kernel.org/netdev/20220727064321.2953971-1-mw@xxxxxxxxxxxx/t/ The ultimate goal of these changes is to prepare the DSA to use ACPI in future, which works locally on my branches [1][2], however, this part needs to be handled separately on the lists, as discussed in v1. The patchset is based and tested on top of pure net-next/main branch. Each commit was checked on: * On EspressoBIN * On SolidRun CN913x CEx7 Eval Board Any comments or remarks will be appreciated. Best regards, Marcin [1] https://github.com/semihalf-wojtas-marcin/Linux-Kernel/commits/dsa-acpi-dev [2] https://github.com/semihalf-wojtas-marcin/edk2-platforms/commits/dsa-acpi-v2 Changelog v3 -> v4: 1/8: * Improve commit message. 2/8: * Improve handling the old 'fixed-link' binding in fwnode_phy_is_fixed_link() * Stop shadowing the real error codes in fwnode_phy_register_fixed_link() 3/8 * Make "label" property optional again * Fix mt7530 compile error reported by kernel test robot <lkp@xxxxxxxxx> * Simplify code update in mv88e6xxx 4/8 * Improve commit message 5/8 * Improve commit message 7/8 * Update dev_dbg message 8/8 * Move fwnode declaration * Simplify obtaining match_data Changelog v2 -> v3: 1/8: * Replace forward declaration s/device_node/fwnode_handle/ in include/linux/phy_fixed.h * Add Florian's RB * 3/8: * Extend lines width in the commit message. * While dropping dp->dn fields in the drivers, switch to fwnode_ API in the updated places. * 5/8: * Update routine name to fwnode_find_parent_dev_match() * Improve comment section * Move the definition adjacent to a group of fwnode APIs operating on parents Changelog v1 -> v2: 1/8 * Drop unnecessary check in fixed_phy_get_gpiod() * Improve line breaking * Use device_set_node & dev_fwnode 2/8 * Switch to fwnode_property_count_u32 and fix comparison in if statement. 3/8 * Drop dn usage entirely and use dp->fwnode only. Update all dependent drivers to use to_of_node. * Use device_set_node, dev_fwnode & device_get_named_child_node * Replace '_of' routines suffix with '_fw' 4/8 * Use device_set_node 5/8 * New patch 6/8 * Use device_match_fwnode * Restore EXPORT_SYMBOL() 7/8 * Get rid of of_mdiobus_register_device 8/8 * Use dev_fwnode in mv88e6xxx_probe * Simplify condition checks in mv88e6xxx_probe as suggested by Andy Marcin Wojtas (8): net: phy: fixed_phy: switch to fwnode_ API net: mdio: switch fixed-link PHYs API to fwnode_ net: dsa: switch to device_/fwnode_ APIs net: mvpp2: initialize port fwnode pointer device property: introduce fwnode_find_parent_dev_match net: core: switch to fwnode_find_net_device_by_node() net: mdio: introduce fwnode_mdiobus_register_device() net: dsa: mv88e6xxx: switch to device_/fwnode_ APIs include/linux/etherdevice.h | 1 + include/linux/fwnode_mdio.h | 22 ++++ include/linux/of_net.h | 6 - include/linux/phy_fixed.h | 6 +- include/linux/property.h | 1 + include/net/dsa.h | 2 +- net/dsa/port.h | 4 +- drivers/base/property.c | 23 ++++ drivers/net/dsa/mt7530.c | 6 +- drivers/net/dsa/mv88e6xxx/chip.c | 57 ++++----- drivers/net/dsa/qca/qca8k-8xxx.c | 2 +- drivers/net/dsa/realtek/rtl8365mb.c | 2 +- drivers/net/ethernet/marvell/mvpp2/mvpp2_main.c | 2 +- drivers/net/mdio/fwnode_mdio.c | 125 ++++++++++++++++++++ drivers/net/mdio/of_mdio.c | 112 +----------------- drivers/net/phy/fixed_phy.c | 39 +++--- net/core/net-sysfs.c | 25 ++-- net/dsa/dsa.c | 118 +++++++++--------- net/dsa/port.c | 85 +++++++------ net/dsa/slave.c | 7 +- 20 files changed, 341 insertions(+), 304 deletions(-) -- 2.29.0