Re: [PATCH] ACPI: PAD: use sysfs_emit() to instead of scnprintf()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Nov 29, 2022 at 12:32 PM <ye.xingchen@xxxxxxxxxx> wrote:
>
> From: ye xingchen <ye.xingchen@xxxxxxxxxx>
>
> Replace the open-code with sysfs_emit() to simplify the code.
>
> Signed-off-by: ye xingchen <ye.xingchen@xxxxxxxxxx>

Can you please send one combo patch for this for all of the affected
code in drivers/acpi/?

> ---
>  drivers/acpi/acpi_pad.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/acpi/acpi_pad.c b/drivers/acpi/acpi_pad.c
> index edbb28faee2a..02f1a1b1143c 100644
> --- a/drivers/acpi/acpi_pad.c
> +++ b/drivers/acpi/acpi_pad.c
> @@ -287,7 +287,7 @@ static ssize_t rrtime_store(struct device *dev,
>  static ssize_t rrtime_show(struct device *dev,
>         struct device_attribute *attr, char *buf)
>  {
> -       return scnprintf(buf, PAGE_SIZE, "%d\n", round_robin_time);
> +       return sysfs_emit(buf, "%d\n", round_robin_time);
>  }
>  static DEVICE_ATTR_RW(rrtime);
>
> @@ -309,7 +309,7 @@ static ssize_t idlepct_store(struct device *dev,
>  static ssize_t idlepct_show(struct device *dev,
>         struct device_attribute *attr, char *buf)
>  {
> -       return scnprintf(buf, PAGE_SIZE, "%d\n", idle_pct);
> +       return sysfs_emit(buf, "%d\n", idle_pct);
>  }
>  static DEVICE_ATTR_RW(idlepct);
>
> --
> 2.25.1



[Index of Archives]     [Linux IBM ACPI]     [Linux Power Management]     [Linux Kernel]     [Linux Laptop]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux