On Fri, Nov 05, 2021 at 09:39:42PM +0200, Andy Shevchenko wrote: > > Anyway, what's the "upper layer"? Is that "struct device" or "struct > > swnode"? I suppose you meant: > > struct device here. > > > - Remove "secondary" field from "struct fwnode_handle". > > - Replace "fwnode" from "upper layer" with > > "struct list_head fwnode_head;". > > - Modify all functions in "software_node_ops" to use "fwnode_head". > > > > Is that correct? > > Yes. > > It might be a bit complicated taking into account how much fwnode is > spreaded in the kernel... Basically, you need to fix all direct > accesses to the dev->fwnode first. > Besides that you need to check that fwnode, which is used out of the > device scope, like in IRQ domains, doesn't use secondary pointer(s). > > This nevertheless adds a lot of flexibility and we may add whatever > type of fwnodes and mix them together. Okay, here is my plan until someone still has an idea to avoid a redesign. Frist, fixes all dev->fwnode / dev.fwnode to use dev_fwnode(). This could be a standalone tree-wide patchset going out to avoid heavy-lifting later. Then, we can create another patchset on top. I have audited "irq_domain" but not seen any "secondary" leakage. Struct "cht_int33fe_data" does have some need to fix. Rename set_secondary_fwnode() to insert_secondary_fwnode(). Fix things in drivers/base/core.c, swnode.c etc to use the new fwnode_head and anything I can't think of right now. Since we will have multiple "software_node" (secondary fwnode:s) for a single "device". What would be the usual way to deal with a linked-list in the sysfs? I can think of just let "software_node" become a directory to host a list of symlinks named from swnode->id. Thoughts?