On Mon, Jul 12, 2021 at 8:36 PM Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > On Mon, Jul 12, 2021 at 07:25:55PM +0200, Rafael J. Wysocki wrote: > > From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx> > > > > Get rid of acpi_platform_notify() which is redundant and > > make device_platform_notify() in the driver core call > > acpi_device_notify() and acpi_device_notify_remove() directly. > > > + if (action == KOBJ_ADD) > > + acpi_device_notify(dev); > > + else if (action == KOBJ_REMOVE) > > + acpi_device_notify_remove(dev); > > In most of the cases we are using switch-case approach with > KOBJ_ADD/KOBJ_REMOVE. Would it make sense to keep that pattern? Well, this goes away in the next patches anyway.