On Fri, Apr 16, 2021 at 1:58 AM Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > > On Fri, Apr 16, 2021 at 8:28 AM Dan Williams <dan.j.williams@xxxxxxxxx> wrote: > > > > On Thu, Apr 15, 2021 at 6:59 AM Andy Shevchenko > > <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > > > > > Strictly speaking the comparison between guid_t and raw buffer > > > is not correct. Import GUID to variable of guid_t type and then > > > compare. > > > > Hmm, what about something like the following instead, because it adds > > safety. Any concerns about evaluating x twice in a macro should be > > alleviated by the fact that ARRAY_SIZE() will fail the build if (x) is > > not an array. > > ARRAY_SIZE doesn't check type. See __must_be_array. > I don't like hiding ugly casts like this. See PTR_ERR, ERR_PTR, ERR_CAST. There's nothing broken about the way the code currently stands, so I'd rather try to find something to move the implementation forward than sideways.