* Matthew Wilcox <matthew@xxxxxx>: > On Wed, Nov 14, 2007 at 12:37:29PM -0700, Alex Chiang wrote: > > Register one slot per slot, rather than one slot per function. > > Change the name of the slot to fake%d instead of the pci address. > > > +#define SLOT_NAME_SIZE KOBJ_NAME_LEN > > Defined, then never used ... how about s/KOBJ_NAME_LEN/8/, then use > SLOT_NAME_SIZE throughout? Here's another try with your suggestion. From: Alex Chiang <achiang@xxxxxx> Register one slot per slot, rather than one slot per function. Change the name of the slot to fake%d instead of the pci address. Signed-off-by: Alex Chiang <achiang@xxxxxx> Signed-off-by: Matthew Wilcox <matthew@xxxxxx> --- drivers/pci/hotplug/fakephp.c | 82 ++++++++++++++++------------------------- 1 files changed, 32 insertions(+), 50 deletions(-) diff --git a/drivers/pci/hotplug/fakephp.c b/drivers/pci/hotplug/fakephp.c index 027f686..1759ea1 100644 --- a/drivers/pci/hotplug/fakephp.c +++ b/drivers/pci/hotplug/fakephp.c @@ -59,10 +59,13 @@ #define DRIVER_AUTHOR "Greg Kroah-Hartman <greg@xxxxxxxxx>" #define DRIVER_DESC "Fake PCI Hot Plug Controller Driver" +#define SLOT_NAME_SIZE 8 + struct dummy_slot { struct list_head node; struct hotplug_slot *slot; struct pci_dev *dev; + char name[SLOT_NAME_SIZE]; }; static int debug; @@ -93,6 +96,7 @@ static int add_slot(struct pci_dev *dev) struct dummy_slot *dslot; struct hotplug_slot *slot; int retval = -ENOMEM; + static int count = 1; slot = kzalloc(sizeof(struct hotplug_slot), GFP_KERNEL); if (!slot) @@ -106,13 +110,14 @@ static int add_slot(struct pci_dev *dev) slot->info->max_bus_speed = PCI_SPEED_UNKNOWN; slot->info->cur_bus_speed = PCI_SPEED_UNKNOWN; - slot->name = &dev->dev.bus_id[0]; - dbg("slot->name = %s\n", slot->name); - dslot = kmalloc(sizeof(struct dummy_slot), GFP_KERNEL); if (!dslot) goto error_info; + slot->name = dslot->name; + snprintf(slot->name, SLOT_NAME_SIZE, "fake%d", count++); + dbg("slot->name = %s\n", slot->name); + slot->ops = &dummy_hotplug_slot_ops; slot->release = &dummy_release; slot->private = dslot; @@ -141,17 +146,17 @@ error: static int __init pci_scan_buses(void) { struct pci_dev *dev = NULL; - int retval = 0; + int lastslot = 0; while ((dev = pci_get_device(PCI_ANY_ID, PCI_ANY_ID, dev)) != NULL) { - retval = add_slot(dev); - if (retval) { - pci_dev_put(dev); - break; - } + if (PCI_FUNC(dev->devfn) > 0 && + lastslot == PCI_SLOT(dev->devfn)) + continue; + lastslot = PCI_SLOT(dev->devfn); + add_slot(dev); } - return retval; + return 0; } static void remove_slot(struct dummy_slot *dslot) @@ -275,23 +280,9 @@ static int enable_slot(struct hotplug_slot *hotplug_slot) return -ENODEV; } -/* find the hotplug_slot for the pci_dev */ -static struct hotplug_slot *get_slot_from_dev(struct pci_dev *dev) -{ - struct dummy_slot *dslot; - - list_for_each_entry(dslot, &slot_list, node) { - if (dslot->dev == dev) - return dslot->slot; - } - return NULL; -} - - static int disable_slot(struct hotplug_slot *slot) { struct dummy_slot *dslot; - struct hotplug_slot *hslot; struct pci_dev *dev; int func; @@ -301,36 +292,27 @@ static int disable_slot(struct hotplug_slot *slot) dbg("%s - physical_slot = %s\n", __FUNCTION__, slot->name); - /* don't disable bridged devices just yet, we can't handle them easily... */ - if (dslot->dev->subordinate) { - err("Can't remove PCI devices with other PCI devices behind it yet.\n"); - return -ENODEV; - } - /* search for subfunctions and disable them first */ - if (!(dslot->dev->devfn & 7)) { - for (func = 1; func < 8; func++) { - dev = pci_get_slot(dslot->dev->bus, - dslot->dev->devfn + func); - if (dev) { - hslot = get_slot_from_dev(dev); - if (hslot) - disable_slot(hslot); - else { - err("Hotplug slot not found for subfunction of PCI device\n"); - return -ENODEV; - } - pci_dev_put(dev); - } else - dbg("No device in slot found\n"); + for (func = 7; func >= 0; func--) { + dev = pci_get_slot(dslot->dev->bus, dslot->dev->devfn + func); + if (!dev) + continue; + + /* don't disable bridged devices just yet, we can't handle + * them easily... */ + if (dev->subordinate) { + err("Can't remove PCI devices with other PCI devices behind it yet.\n"); + return -ENODEV; } - } - /* remove the device from the pci core */ - pci_remove_bus_device(dslot->dev); - /* blow away this sysfs entry and other parts. */ - remove_slot(dslot); + /* remove the device from the pci core */ + pci_remove_bus_device(dslot->dev); + /* blow away this sysfs entry and other parts. */ + remove_slot(dslot); + + pci_dev_put(dev); + } return 0; } -- 1.5.3.1.1.g1e61 - To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html