> Ok, missed that. How about something like the following? I've changed > some of the interfaces slightly, so the pata_acpi driver would need to > be altered to match. This gets rid of the CABLE_SATA checking in Close but no cigar. The pata_acpi driver needs to be able to pass its own pointer for gtf as it wants to keep multiple states to hand. > acpi_status status; > struct acpi_buffer output; > > + if (!ap->acpi_port_link || !ap->acpi_port_link->is_pata) > + return -ENODEV; Make ap->acpi_port_link a local variable and it is easier to read and smaller and faster, need to pass the struct to gtm/stm from the caller - easily pushed up a layer. > -int ata_acpi_stm(const struct ata_port *ap, void *handle, struct acpi_gtm *stm) > +int ata_acpi_stm(const struct ata_port *ap) Ditto Otherwise looks good. - To unsubscribe from this list: send the line "unsubscribe linux-acpi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html