gre tunnel question

Linux Advanced Routing and Traffic Control

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello,

I am trying to implement a Broadcast GRE Tunnel that is described at
this link http://linux-ip.net/gl/ip-tunnels/node9.html but it doesnt
seem to be working.

I am seeing the GRE packets for both networks on both sniffers but the
tcpdump i tun0 doesnt show any of the packets from the remote end
getting there.

Can you tell me if I have something misconfigured or if what I am trying
to do is impossible.

Ive listed all the configuration information under the ascii drawing
 
Basically trying to get routing information from network A to network B
without knowing what the ip address is for remote eth0 is, hence the
multicast address, and keeping the overhead as low as possible.


Thanks.
 

               Router         1      2         Router
+---------+  +--------+     +---+  +---+     +--------+  +---------+
|network A|--| Net-99 |-----|INE|--|INE|-----| Net-77 |--|network B|
+---------+  +--------+  |  +---+  +---+  |  +--------+  +---------+
             eth1  eth0  |  PT CT  CT PT  |  eth0  eth1
                         |                |
                     +-------+        +-------+
                     |sniffer|        |sniffer|
                     +-------+        +-------+



Net99 eth0: 172.16.1.240/24
Net99 eth1: 99.99.99.99/8

Net77 eth0: 172.16.2.240/24
Net77 eth1: 77.77.77.77/8

INE - Inline Network Encryptor

INE1 PT: 172.16.1.1/24
INE1 CT: 10.0.0.1/24

INE2 PT: 172.16.2.1/24
INE2 CT: 10.0.0.2/24

Router Net99
============

Create Tunnel
-------------

modprobe ip-gre
ip tunnel add tun0 mode gre remote 239.0.0.1 local 172.16.1.240 dev eth0
ip addr add 10.20.1.1/24 dev tun0
ip link set tun0 up
ip link seg gre0 up

========================================================================

zebra.conf
----------

hostname net99
password itac
enable password itac

interface eth0
  description To KG-175B 789
  ip address 172.16.1.240/24
  multicast

interface eth1
  description To airborne network
  ip address 99.99.99.99/8
  multicast

interface tun0
  description tunnel for ospf
  ip address 10.20.1.1/24
  multicast


ip route 0.0.0.0/0 172.16.1.1

========================================================================

ospfd.conf
----------

router ospf
  ospf router-id 172.16.1.240
  ospf abr-type cisco
  redistribute connected
  network 10.20.1.0/24 area 0
  network 99.0.0.0/8 area 1
  area 1 stub

========================================================================

Router Net77
============

Create Tunnel
-------------

modprobe ip-gre
ip tunnel add tun0 mode gre remote 239.0.0.1 local 172.16.2.240 dev eth0
ip addr add 10.20.1.2/24 dev tun0
ip link set tun0 up
ip link set gre0 up

========================================================================

zebra.conf
----------

hostname net77
password itac
enable password itac

interface eth0
  description To KG-175E 23969
  ip address 172.16.2.240/24
  multicast

interface eth1
  description To airborne network
  ip address 77.77.77.77/8
  multicast

interface tun0
  description tunnel for ospf
  ip address 10.20.1.2/24
  multicast


ip route 0.0.0.0/0 172.16.1.1

========================================================================

ospf.conf
---------

router ospf
  ospf router-id 172.16.2.240
  ospf abr-type cisco
  redistribute connected
  network 10.20.1.0/24 area 0
  network 77.0.0.0/8 area 1
  area 1 stub

========================================================================

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
LARTC mailing list
LARTC@xxxxxxxxxxxxxxx
http://mailman.ds9a.nl/cgi-bin/mailman/listinfo/lartc

[Index of Archives]     [LARTC Home Page]     [Netfilter]     [Netfilter Development]     [Network Development]     [Bugtraq]     [GCC Help]     [Yosemite News]     [Linux Kernel]     [Fedora Users]
  Powered by Linux