On Fri, 2013-11-15 at 11:01 +0530, Bharat Bhushan wrote: > From: Bharat Bhushan <bharat.bhushan@xxxxxxxxxxxxx> > > v2->v3 > - Returning pte pointer rather than pte as suggested by Scott > - Also removed PAGE_SPLITTING as this need to be handled by caller > > v1->v2 > - Removed _PAGE_BUSY loop as suggested by PaulS. > - Added check for PAGE_SPLITTING > > kvm: powerpc: use cache attributes from linux pte > - 1st Patch fixes a bug in booke (detail in patch) > - 2nd patch is renaming the linux_pte_lookup_function() just for clarity. > There is not functional change. > - 3nd Patch adds a Linux pte lookup function. > - 4th Patch uses the above defined function and setup TLB.wimg accordingly > > Bharat Bhushan (4): > kvm: booke: clear host tlb reference flag on guest tlb invalidation > kvm: book3s: rename lookup_linux_pte() to > lookup_linux_pte_and_update() > kvm: powerpc: define a linux pte lookup function > kvm: powerpc: use caching attributes as per linux pte > > arch/powerpc/include/asm/kvm_host.h | 2 +- > arch/powerpc/include/asm/pgtable.h | 21 +++++++++++++ > arch/powerpc/kvm/book3s_hv_rm_mmu.c | 8 +++-- > arch/powerpc/kvm/booke.c | 1 + > arch/powerpc/kvm/e500.h | 8 +++-- > arch/powerpc/kvm/e500_mmu_host.c | 55 +++++++++++++++++++--------------- > 6 files changed, 64 insertions(+), 31 deletions(-) Reviewed-by: Scott Wood <scottwood@xxxxxxxxxxxxx> with patch 4/4 replaced by v4. -Scott -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html