On Sun, 2013-06-16 at 14:26 +1000, Benjamin Herrenschmidt wrote: > > +int realmode_get_page(struct page *page) > > +{ > > + if (PageCompound(page)) > > + return -EAGAIN; > > + > > + get_page(page); > > + > > + return 0; > > +} Shouldn't it be get_page_unless_zero ? Cheers, Ben. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html