On Fri, Jan 11, 2013 at 06:25:18PM +0900, Takuya Yoshikawa wrote: > Patches 1 to 3 are trivial. > > Patch 4 is the main cause of the increased lines, but I think the new > code makes it easier to understand why each condition in > __kvm_set_memory_region() is there. > > If you don't agree with patch 4, please consider taking the rest of the > series at this time. > > Takuya Yoshikawa (4): > KVM: set_memory_region: Don't jump to out_free unnecessarily > KVM: set_memory_region: Don't check for overlaps unless we create or move a slot > KVM: set_memory_region: Remove unnecessary variable memslot > KVM: set_memory_region: Identify the requested change explicitly > > virt/kvm/kvm_main.c | 94 ++++++++++++++++++++++++++++++++------------------- > 1 files changed, 59 insertions(+), 35 deletions(-) > Applied 1-3. It is not clear whether kvm_iommu_map_pages() should be called when flags change, so not applying 4 for now. -- Gleb. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html