On 27/09/12 15:13, Will Deacon wrote: > On Wed, Sep 26, 2012 at 02:43:14AM +0100, Christoffer Dall wrote: >> On 09/25/2012 11:20 AM, Will Deacon wrote: >>> >>>> +static inline u32 *vcpu_pc(struct kvm_vcpu *vcpu) >>>> +{ >>>> + return vcpu_reg(vcpu, 15); >>>> +} >>> >>> If you stick a struct pt_regs into struct kvm_regs, you could reuse ARM_pc >>> here etc. >>> >> >> I prefer not to, because we'd have those registers presumably for usr >> mode and then we only define the others explicit. I think it's much >> clearer to look at kvm_regs today. > > I disagree and think that you should reuse as much of the arch/arm/ code as > possible. Not only does it make it easier to read by people who are familiar > with that code (and in turn get you more reviewers) but it also means that > we limit the amount of duplication that we have. > > I think Marc (CC'd) had a go at this with some success. Yup, I have it converted already. It requires a number of changes, but I took this opportunity to do some other cleanup (world switch save/restore code, mostly). Patches are at the top of mu kvm-cleanup branch. M. -- Jazz is not dead. It just smells funny... -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html