Sasha Levin wrote: > On Sun, 2011-12-25 at 21:00 +0200, Sasha Levin wrote: >> On Sun, 2011-12-25 at 15:03 +0200, Avi Kivity wrote: >>> + if (apic) { >>> + if (best->ecx & bit(X86_FEATURE_TSC_DEADLINE_TIMER)) >>> + apic->lapic_timer.timer_mode_mask = 3 << 17; >>> + else >>> + apic->lapic_timer.timer_mode_mask = 1 << 17; >>> + } >> >> Can we change these to be: >> >> if(...) >> apic->lapic_timer.timer_mode_mask = APIC_LVT_TIMER_PERIODIC | >> APIC_LVT_TIMER_TSCDEADLINE; else apic->lapic_timer.timer_mode_mask >> = APIC_LVT_TIMER_PERIODIC; > > Actually, > > apic->lapic_timer.timer_mode_mask = APIC_LVT_TIMER_PERIODIC; > if(...) > apic->lapic_timer.timer_mode_mask |= APIC_LVT_TIMER_TSCDEADLINE; Is it good semantically? APIC_LVT_TIMER_PERIODIC and APIC_LVT_TIMER_TSCDEADLINE is timer mode, where timer_mode_mask is timer mode mask. Thanks, Jinsong-- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html