Re: [RFC 01/12] kvm tools: Split kvm_cmd_run into init, work and uninit

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 12/20/2011 06:09 PM, Sasha Levin wrote:
> On Mon, 2011-12-19 at 23:26 +0200, Pekka Enberg wrote:
>> On Mon, 2011-12-19 at 15:58 +0200, Sasha Levin wrote:
>>> +int kvm_cmd_run(int argc, const char **argv, const char *prefix)
>>> +{
>>> +	int r, ret;
>>> +
>>> +	r = kvm_cmd_run_init(argc, argv);
>>> +	ret = kvm_cmd_run_work();
>>> +	r = kvm_cmd_run_uninit(ret);
>>> +
>>> +	return ret;
>>>  }
>>
>> What's going on here? Why do you bother saving 'r' if you don't use it
>> for anything?
> 
> It was part of my plans to get kvm_cmd_run_{init, uninit} as a simple

Can we have a shorter name for 'uninit', e.g. 'fini', thus we will have
{init, fini}.

> for(;;) through a init/uninit function pointer array, right now it's
> simply meaningless there.
> 


-- 
Asias He
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux