On Mon, Oct 17, 2011 at 01:51:00PM +0200, Jan Kiszka wrote: > On 2011-10-17 13:46, Michael S. Tsirkin wrote: > > On Mon, Oct 17, 2011 at 11:27:42AM +0200, Jan Kiszka wrote: > >> Will be used for generating and distributing MSI messages, both in > >> emulation mode and under KVM. > >> > >> Signed-off-by: Jan Kiszka <jan.kiszka@xxxxxxxxxxx> > > > > I would add > > > > uint64_t msix_get_address(dev, vector) > > uint64_t msix_get_data(dev, vector) > > > > and same for msi. > > > > this would minimise the changes while still making it > > possible to avoid code duplication in kvm. > > I'm introducing msi[x]_message_from_vector for that purpose later on. Or > what do you mean? > > Jan It does not look like everyone actually wants the structure, users seem to put it on stack and then immediately unwrap it to get at the address/data. So two accessorts get_data + get_address instead of one, will remove the need to rework all code to use the structure. > -- > Siemens AG, Corporate Technology, CT T DE IT 1 > Corporate Competence Center Embedded Linux -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html