On Thu, Jul 07, 2011 at 03:18:41AM +0800, Xiao Guangrong wrote: > On 07/07/2011 01:39 AM, Marcelo Tosatti wrote: > > >> -static bool spte_is_bit_cleared(u64 old_spte, u64 new_spte, u64 bit_mask) > >> +static void track_spte_bits(u64 old_spte, u64 keep_bits, bool always_track) > >> { > >> - return (old_spte & bit_mask) && !(new_spte & bit_mask); > >> + if (always_track || > >> + (spte_is_bit_cleared(old_spte, keep_bits, shadow_accessed_mask))) > >> + kvm_set_pfn_accessed(spte_to_pfn(old_spte)); > >> + > >> + if (always_track || > >> + (spte_is_bit_cleared(old_spte, keep_bits, shadow_dirty_mask))) > >> + kvm_set_pfn_dirty(spte_to_pfn(old_spte)); > >> +} > > > > This is much more confusing than previously, please drop it. > > > > What about remove "always_track" parameter? After that, the code should be clear. Its easier to read by having it opencoded as it is now. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html