On 06/15/2011 12:09 PM, Gleb Natapov wrote:
> > Actually, I'd expect most read/writes to benefit from caching, no? > So why don't we just rename kvm_write_guest_cached() to > kvm_write_guest(), and the few places - if any - that need to force > transversing of the gfn mappings, get renamed to > kvm_write_guest_uncached ? > Good idea. I do not see any places where kvm_write_guest_uncached is needed from a brief look. Avi?
kvm_write_guest_cached() needs something to supply the cache, and needs recurring writes to the same location. Neither of these are common (for example, instruction emulation doesn't have either).
> > If done like you said, time spent on the hypervisor is accounted as > steal time. I don't think it is. I thought that this is the point of a steal time. Running other tasks/guests is a hypervisor overhead too after all :) Also what about time spend serving host interrupts between put/get? It will not be accounted as steal time, correct?
With accurate interrupt time accounting, it should be. Otherwise general hypervisor overhead is not steal time.
(i.e. if the host is not overcommitted, steal time should be close to zero). -- error compiling committee.c: too many arguments to function -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html