On Fri, Jun 3, 2011 at 12:19 AM, Sasha Levin <levinsasha928@xxxxxxxxx> wrote: >> +static int cache_table(struct qcow *q, u64 *table, u64 offset) >> +{ >> + struct qcow_l2_cache *n; >> + struct rb_root *r = &q->root; >> + struct qcow_l2_cache *lru; >> + >> + n = calloc(1, sizeof(struct qcow_l2_cache)); > sizeof(*n) > sizeof() should use the variable name itself, not the data type. Check > out chapter 14 in 'Documentation/CodingStyle'. Well, it doesn't matter that much, to be honest. 'n' could use a better name, though - 'cache' or 'c'. Pekka -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html