On Fri, 2011-05-06 at 13:56 +0200, Ingo Molnar wrote: > * Sasha Levin <levinsasha928@xxxxxxxxx> wrote: > > > + bdev->pci_device.irq_pin = pin; > > + bdev->pci_device.irq_line = line; > > One small remaining naming inconsistency caught my eyes. The generic convention > should be something like: > > - structure names should be along the 'struct xyz_device' scheme > > - structure field names should be 'xyz_dev' > > - variable names within xyz driver's .c file should be 'xdev', > but 'xyz_dev' is OK too, especially if used in some other file) > > In that sense, the above should be: > > bdev->pci_dev.irq_pin = pin; > bdev->pci_dev.irq_line = line; > > This could be fixed in a followup patch - and there's more of the same > inconsistency in other driver files as well. > > If such details are sorted out early on in a project's lifetime it will be > applied in a very natural way as the code grows. The struct name there actually refers to a PCI header of a device, and not an actual device. I'll rename it to pci_hdr instead of making it pci_dev, since it looks more confusing than desirable. -- Sasha. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html