On Sat, Apr 16, 2011 at 10:23 AM, Pekka Enberg <penberg@xxxxxxxxxx> wrote: > On Fri, Apr 15, 2011 at 5:18 PM, Prasad Joshi <prasadjoshi124@xxxxxxxxx> wrote: >> Add a new function qcow1_read_cluster() to read a qcow cluster size data at a >> time. The function qcow1_read_sector() is modified to use the function >> qcow1_read_cluster(). >> >> Signed-off-by: Prasad Joshi <prasadjoshi124@xxxxxxxxx> > > I applied patches 1-3 but this patch needs splitting: > > - s/uint64_t/u64/ fixes need to be separate Okay > > - checking for out of bound indices Only new check added is to verify that the cluster offset is less than the size of the cluster. Can this one liner changed be combined with the patch that checks for cluster boundary? Checking for cluster boundary adds a new function and the most of the code from qcow1_read_sector() will be moved to qcow1_read_cluster(). Thanks and Regards, Prasad > > - reads that pass cluster bondaries > > Pekka > -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html