On Sun, Mar 27, 2011 at 02:56:56PM +0200, Gleb Natapov wrote: > On Fri, Mar 25, 2011 at 10:29:04AM +0100, Joerg Roedel wrote: > > @@ -259,6 +267,18 @@ struct x86_emulate_ctxt { > > #define X86EMUL_MODE_PROT32 4 /* 32-bit protected mode. */ > > #define X86EMUL_MODE_PROT64 8 /* 64-bit (long) mode. */ > > > > +enum x86_intercept_stage { > > + x86_icpt_pre_except, > > + x86_icpt_post_except, > > + x86_icpt_post_memaccess, > > +}; > > + > > +enum x86_intercept { > > + x86_intercept_none, > > + > > + nr_x86_intercepts > > +}; > > + > Can we name enums in upper case please? Just did a quick grep and it seems that both, upper and lower case is used in enums throughout the kernel. It makes certainly sense to have it in upper case to make a visual distinction between constants and variables, but for the x86_intercept enum this means clobbering the opcode-tables in the emulator with upper-case strings making them less readable imo. But I change x86_intercept_stage to upper-case in the next version. Joerg -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html