Re: [Qemu-devel] [PATCH 1/3] nmi: convert cpu_index to cpu-index

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Lai Jiangshan <laijs@xxxxxxxxxxxxxx> writes:

> "cpu-index" is better name.
>
> Signed-off-by:  Lai Jiangshan <laijs@xxxxxxxxxxxxxx>
> ---
> diff --git a/hmp-commands.hx b/hmp-commands.hx
> index 4befbe2..8de7aa3 100644
> --- a/hmp-commands.hx
> +++ b/hmp-commands.hx
> @@ -721,7 +721,7 @@ ETEXI
>  #if defined(TARGET_I386)
>      {
>          .name       = "nmi",
> -        .args_type  = "cpu_index:i",
> +        .args_type  = "cpu-index:i",
>          .params     = "cpu",
>          .help       = "inject an NMI on the given CPU",
>          .mhandler.cmd = do_inject_nmi,
> diff --git a/monitor.c b/monitor.c
> index 5d74fe3..c16b39d 100644
> --- a/monitor.c
> +++ b/monitor.c
> @@ -2410,7 +2410,7 @@ static void do_wav_capture(Monitor *mon, const QDict *qdict)
>  static void do_inject_nmi(Monitor *mon, const QDict *qdict)
>  {
>      CPUState *env;
> -    int cpu_index = qdict_get_int(qdict, "cpu_index");
> +    int cpu_index = qdict_get_int(qdict, "cpu-index");
>  
>      for (env = first_cpu; env != NULL; env = env->next_cpu)
>          if (env->cpu_index == cpu_index) {

Fine with me, but it would be nice if we could make up our mind once and
for all whether to use dash or underscore in monitor commands and
arguments.
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]
  Powered by Linux