* MinChan Kim <minchan.kim@xxxxxxxxx> [2010-12-14 19:01:26]: > Hi Balbir, > > On Fri, Dec 10, 2010 at 11:31 PM, Balbir Singh > <balbir@xxxxxxxxxxxxxxxxxx> wrote: > > Move reusable functionality outside of zone_reclaim. > > Make zone_reclaim_unmapped_pages modular > > > > Signed-off-by: Balbir Singh <balbir@xxxxxxxxxxxxxxxxxx> > > --- > > mm/vmscan.c | 35 +++++++++++++++++++++++------------ > > 1 files changed, 23 insertions(+), 12 deletions(-) > > > > diff --git a/mm/vmscan.c b/mm/vmscan.c > > index e841cae..4e2ad05 100644 > > --- a/mm/vmscan.c > > +++ b/mm/vmscan.c > > @@ -2815,6 +2815,27 @@ static long zone_pagecache_reclaimable(struct zone *zone) > > } > > > > /* > > + * Helper function to reclaim unmapped pages, we might add something > > + * similar to this for slab cache as well. Currently this function > > + * is shared with __zone_reclaim() > > + */ > > +static inline void > > +zone_reclaim_unmapped_pages(struct zone *zone, struct scan_control *sc, > > + unsigned long nr_pages) > > +{ > > + int priority; > > + /* > > + * Free memory by calling shrink zone with increasing > > + * priorities until we have enough memory freed. > > + */ > > + priority = ZONE_RECLAIM_PRIORITY; > > + do { > > + shrink_zone(priority, zone, sc); > > + priority--; > > + } while (priority >= 0 && sc->nr_reclaimed < nr_pages); > > +} > > As I said previous version, zone_reclaim_unmapped_pages doesn't have > any functions related to reclaim unmapped pages. The scan control point has the right arguments for implementing reclaim of unmapped pages. > The function name is rather strange. > It would be better to add scan_control setup in function inner to > reclaim only unmapped pages. > > -- > Kind regards, > Minchan Kim -- Three Cheers, Balbir -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html