On Wed, Nov 10, 2010 at 6:21 PM, Michael S. Tsirkin <mst@xxxxxxxxxx> wrote: > On Wed, Nov 10, 2010 at 08:02:12PM +0200, Gleb Natapov wrote: >> On Wed, Nov 10, 2010 at 07:34:12PM +0200, Michael S. Tsirkin wrote: >> > On Wed, Nov 10, 2010 at 07:14:15PM +0200, Gleb Natapov wrote: >> > > >> > > Signed-off-by: Gleb Natapov <gleb@xxxxxxxxxx> >> > >> > Good stuff. We should also consider using this for >> > CLI and monitor. Some comments below. >> > >> > > --- >> > > Âhw/pci.c |  54 ++++++++++++++++++++++++++++++++++++++++++++++++++++++ >> > > Â1 files changed, 54 insertions(+), 0 deletions(-) >> > > >> > > diff --git a/hw/pci.c b/hw/pci.c >> > > index 92aaa85..ab0399c 100644 >> > > --- a/hw/pci.c >> > > +++ b/hw/pci.c >> > > @@ -63,12 +63,14 @@ struct PCIBus { >> > > >> > > Âstatic void pcibus_dev_print(Monitor *mon, DeviceState *dev, int indent); >> > > Âstatic char *pcibus_get_dev_path(DeviceState *dev); >> > > +static char *pcibus_get_fw_dev_path(DeviceState *dev); >> > > >> > > Âstatic struct BusInfo pci_bus_info = { >> > >   Â.name    = "PCI", >> > >   Â.size    = sizeof(PCIBus), >> > >   Â.print_dev Â= pcibus_dev_print, >> > >   Â.get_dev_path = pcibus_get_dev_path, >> > > +  Â.get_fw_dev_path = pcibus_get_fw_dev_path, >> > >   Â.props   Â= (Property[]) { >> > >     ÂDEFINE_PROP_PCI_DEVFN("addr", PCIDevice, devfn, -1), >> > >     ÂDEFINE_PROP_STRING("romfile", PCIDevice, romfile), >> > > @@ -2135,6 +2137,58 @@ static void pcibus_dev_print(Monitor *mon, DeviceState *dev, int indent) >> > >   Â} >> > > Â} >> > > >> > > +static char *pci_dev_fw_name(DeviceState *dev, char *buf, int len) >> > > +{ >> > > +  ÂPCIDevice *d = (PCIDevice *)dev; >> > > +  Âconst char *name = NULL; >> > > + >> > > +#define E(R, N) case R: name = N; break; >> > >> > Straight from underhanded C contest :). >> > Does this macro really buy us all that much? >> Easy typing. > > I am serious about underhanded C. Macros like this one are their tool > of choice. > >> > Split this switch to an inline function, we'll get >> >   case 0x0600: Âreturn "host"; >> > and then we won't need the macro. >> > >> > > + >> > > +  Â/* names taken from pci binding for open firmware */ >> > > +  Âswitch (pci_get_word(d->config + PCI_CLASS_DEVICE)) { >> > > +    ÂE(0x0001, "display"); E(0x0100, "scsi"); E(0x0101, "ide"); >> > > +    ÂE(0x0102, "fdc"); E(0x0103, "ipi"); E(0x0104, "raid"); >> > > +    ÂE(0x0200, "ethernet"); E(0x0201, "token-ring"); ÂE(0x0202, "fddi"); >> > > +    ÂE(0x0203, "atm"); E(0x0300 ... 0x03ff, "display"); E(0x0400, "video"); >> > > +    ÂE(0x0401, "sound"); E(0x0500, "memory"); E(0x0501, "flash"); >> > > +    ÂE(0x0600, "host"); E(0x0601, "isa"); E(0x0602, "eisa"); >> > > +    ÂE(0x0603, "mca"); E(0x0604, "pci"); E(0x0605, "pcmcia"); >> > > +    ÂE(0x0606, "nubus"); E(0x0607, "cardbus"); E(0x0700, "serial"); >> > > +    ÂE(0x0701, "parallel"); E(0x0800, "interrupt-controller"); >> > > +    ÂE(0x0801, "dma-controller"); E(0x0802, "timer"); >> > > +    ÂE(0x0803, "rtc"); E(0x0900, "keyboard"); E(0x0901, "pen"); >> > > +    ÂE(0x0902, "mouse"); E(0x0a00 ... 0x0aff, "dock"); >> > > +    ÂE(0x0b00 ... 0x0bff, "cpu"); E(0x0c00, "fireware"); >> > > +    ÂE(0x0c01, "access-bus"); E(0x0c02, "ssa"); E(0x0c03, "usb"); >> > > +    ÂE(0x0c04, "fibre-channel"); >> > >> > Please use constants from >> > hw/pci_ids.h >> OK. But this will make macro even more handy :) Are all classes defined there? > > Not in qemu, but the linux pci_ids has them all I think. > So just add stuff from there to qemu. The PCI database in OpenBIOS may also be handy: http://tracker.coreboot.org/trac/openbios/browser/trunk/openbios-devel/drivers/pci_database.c -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html