* Christoph Lameter <cl@xxxxxxxxx> [2010-11-03 09:35:33]: > On Fri, 29 Oct 2010, Balbir Singh wrote: > > > A lot of the code is borrowed from zone_reclaim_mode logic for > > __zone_reclaim(). One might argue that the with ballooning and > > KSM this feature is not very useful, but even with ballooning, > > Interesting use of zone reclaim. I am having a difficult time reviewing > the patch since you move and modify functions at the same time. Could you > separate that out a bit? > Sure, I'll split it out into more readable bits and repost the mm versions first. > > +#define UNMAPPED_PAGE_RATIO 16 > > Maybe come up with a scheme that allows better configuration of the > mininum? I think in some setting we may want an absolute limit and in > other a fraction of something (total zone size or working set?) > Are you suggesting a sysctl or computation based on zone size and limit, etc? I understand it to be the latter. > > > +bool should_balance_unmapped_pages(struct zone *zone) > > +{ > > + if (unmapped_page_control && > > + (zone_unmapped_file_pages(zone) > > > + UNMAPPED_PAGE_RATIO * zone->min_unmapped_pages)) > > + return true; > > + return false; > > +} > Thanks for your review. -- Three Cheers, Balbir -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html