Incorporated feedback. txburst= and txtimer= are now "x-" prefixed developer options. I added a tx= option, because I do want there to be a supported way to switch between TX strategies. This also drops the magic value of txtimer= 1 or 0 (setting default timeout or switching modes). I also dropped the trickiness around only enabling the bottom half for the iothread since Anthony indicates we don't care about performance for the non-iothread case. New performance data against both qemu.git and qemu-kvm.git: https://spreadsheets.google.com/pub?key=0AoEm50Bac2U7dGdlREhrWUpPVEdMcTJaX0RjSEgtc3c&hl=en&single=true&gid=0&output=html This shows the base performance versus patched with new default for various packet sizes and netperf test loads. The guest is a 2-way SMP, connected directly to the host via a tap (no bridge). Thanks, Alex --- Alex Williamson (4): virtio-net: Introduce a new bottom half packet TX virtio-net: Rename tx_timer_active to tx_waiting virtio-net: Limit number of packets sent per TX flush virtio-net: Make tx_timer timeout configurable hw/s390-virtio-bus.c | 8 +++ hw/s390-virtio-bus.h | 1 hw/syborg_virtio.c | 8 +++ hw/virtio-net.c | 129 +++++++++++++++++++++++++++++++++++++++++--------- hw/virtio-net.h | 14 +++++ hw/virtio-pci.c | 8 +++ hw/virtio.h | 4 +- 7 files changed, 144 insertions(+), 28 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html