On 08/31/2010 03:27 PM, Michael S. Tsirkin wrote:
On Fri, Aug 27, 2010 at 04:36:59PM -0600, Alex Williamson wrote:
Add the ability to configure the tx_timer timeout and add a bottom
half tx handler that typically shows a nice perf boost over the
time based approach. See last patch for perf details. Make this
the new default when the iothread is enabled. Thanks,
Alex
As a further thought, maybe it would help to have a
separate namespace for unsupported, developer-only parameters.
Thoughts?
We already have an undocumented one, just prefix with 'x-' to indicate
that it's experimental.
Regards,
Anthony Liguori
---
Alex Williamson (5):
virtio-net: Switch default to new bottom half TX handler for iothread
virtio-net: Introduce a new bottom half packet TX
virtio-net: Rename tx_timer_active to tx_waiting
virtio-net: Limit number of packets sent per TX flush
virtio-net: Make tx_timer timeout configurable
hw/s390-virtio-bus.c | 6 ++
hw/s390-virtio-bus.h | 4 ++
hw/syborg_virtio.c | 10 +++-
hw/virtio-net.c | 129 ++++++++++++++++++++++++++++++++++++++++----------
hw/virtio-net.h | 2 -
hw/virtio-pci.c | 10 +++-
hw/virtio.h | 9 +++
7 files changed, 137 insertions(+), 33 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html