On 08/29/2010 05:16 PM, Avi Kivity wrote: > On 08/28/2010 03:00 PM, Xiao Guangrong wrote: >> Add the debugfs file named 'mmu-debug', we can disable/enable mmu >> audit by >> this file: >> >> enable: >> echo 1> debugfs/kvm/mmu-debug >> >> disable: >> echo 0> debugfs/kvm/mmu-debug > > > Better as a runtime rw module parameter perhaps? At least it avoids the > large debugfs callbacks. > Yeah, it's a good idea. > Also, call it audit to preserve the name. OK >> + >> +TRACE_EVENT( >> + kvm_mmu_audit, >> + TP_PROTO(struct kvm_vcpu *vcpu, const char *msg), >> + TP_ARGS(vcpu, msg), >> + >> + TP_STRUCT__entry( >> + __field(struct kvm_vcpu *, vcpu) >> + __field(const char *, msg) >> + ), > > enum instead of char *, maybe something in userspace can make use of this. > OK >> + >> + TP_fast_assign( >> + __entry->vcpu = vcpu; >> + __entry->msg = msg; >> + ), >> + >> + TP_printk("%s", __entry->msg) > > Here, of course, you can use print_symbolic() to preserve readability. OK Will fix them in the next version. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html