On Wed, Aug 18, 2010 at 10:36 AM, Avi Kivity <avi@xxxxxxxxxx> wrote: > Signed-off-by: Avi Kivity <avi@xxxxxxxxxx> > --- > arch/x86/kvm/x86.c | 1 + > 1 files changed, 1 insertions(+), 0 deletions(-) > > diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c > index f6a31a1..e2b0e36 100644 > --- a/arch/x86/kvm/x86.c > +++ b/arch/x86/kvm/x86.c > @@ -3967,6 +3967,7 @@ int kvm_inject_realmode_interrupt(struct kvm_vcpu *vcpu, int irq) > > vcpu->arch.emulate_ctxt.decode.op_bytes = 2; > vcpu->arch.emulate_ctxt.decode.ad_bytes = 2; > + vcpu->arch.emulate_ctxt.decode.eip = kvm_rip_read(vcpu); I think it'd make more sense to make vcpu->arch.emulate_ctxt.decode.eip = vcpu->arch.emulate_ctxt.eip, as we already initlialize the emulation context eip. It's not going to make any real difference, but it's more readable this way I suppose, and is symmetric to the assignment of the emulation context eip value after the call to emulate_int_real() > ret = emulate_int_real(&vcpu->arch.emulate_ctxt, &emulate_ops, irq); > > if (ret != X86EMUL_CONTINUE) > -- > 1.7.1 > > -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html