Re: [PATCH v3 5/7] hw/hyperv/syndbg: common compilation unit

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 3/7/25 12:56, Philippe Mathieu-Daudé wrote:
On 7/3/25 20:37, Pierrick Bouvier wrote:
Replace TARGET_PAGE.* by runtime calls
We assume that page size is 4KB only, to dimension buffer size for
receiving message.

Reviewed-by: Richard Henderson <richard.henderson@xxxxxxxxxx>
Signed-off-by: Pierrick Bouvier <pierrick.bouvier@xxxxxxxxxx>
---
   hw/hyperv/syndbg.c    | 10 +++++++---
   hw/hyperv/meson.build |  2 +-
   2 files changed, 8 insertions(+), 4 deletions(-)

diff --git a/hw/hyperv/syndbg.c b/hw/hyperv/syndbg.c
index d3e39170772..0ec71d9bfb8 100644
--- a/hw/hyperv/syndbg.c
+++ b/hw/hyperv/syndbg.c
@@ -14,7 +14,7 @@
   #include "migration/vmstate.h"
   #include "hw/qdev-properties.h"
   #include "hw/loader.h"
-#include "cpu.h"
+#include "exec/target_page.h"
   #include "hw/hyperv/hyperv.h"
   #include "hw/hyperv/vmbus-bridge.h"
   #include "hw/hyperv/hyperv-proto.h"
@@ -183,12 +183,14 @@ static bool create_udp_pkt(HvSynDbg *syndbg, void *pkt, uint32_t pkt_len,
       return true;
   }
+#define MSG_BUFSZ 4096

(4 * KiB) is more readable, but, as a matter of style, I won't
object if you insist.


Sure, I can change to that.

Reviewed-by: Philippe Mathieu-Daudé <philmd@xxxxxxxxxx>






[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux