Re: [kvm-unit-tests PATCH] lib: s390x: css: Cleanup chsc inline assembly

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu,  6 Feb 2025 14:58:49 +0000
Janosch Frank <frankja@xxxxxxxxxxxxx> wrote:

> Name the CHSC command block pointer instead of naming it "p".
> 
> Also replace the two "m" constraints with a memory globber so the
> constraints are easier to read.
> 
> Signed-off-by: Janosch Frank <frankja@xxxxxxxxxxxxx>

Reviewed-by: Claudio Imbrenda <imbrenda@xxxxxxxxxxxxx>

> ---
> 
> To me it makes more sense to have a separate commit that has a message
> explaining why we changed it instead of sending a v2, so here it is.

makes sense

> 
> ---
>  lib/s390x/css.h | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/lib/s390x/css.h b/lib/s390x/css.h
> index 06bb59c7..167f8e83 100644
> --- a/lib/s390x/css.h
> +++ b/lib/s390x/css.h
> @@ -364,16 +364,16 @@ bool get_chsc_scsc(void);
>  #define CHSC_RSP_EBUSY	0x000B
>  #define CHSC_RSP_MAX	0x000B
>  
> -static inline int _chsc(void *p)
> +static inline int _chsc(void *com_blk)
>  {
>  	int cc;
>  
> -	asm volatile(" .insn   rre,0xb25f0000,%2,0\n"
> +	asm volatile(" .insn   rre,0xb25f0000,%[com_blk],0\n"
>  		     " ipm     %[cc]\n"
>  		     " srl     %[cc],28\n"
> -		     : [cc] "=d" (cc), "=m" (p)
> -		     : "d" (p), "m" (p)
> -		     : "cc");
> +		     : [cc] "=d" (cc)
> +		     : [com_blk] "d" (com_blk)
> +		     : "cc", "memory");
>  
>  	return cc;
>  }





[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux