Anthony Liguori <anthony@xxxxxxxxxxxxx> writes: > On 06/15/2010 11:16 AM, Cam Macdonell wrote: >> How does this look for marking the device as non-migratable? It adds a field >> 'no_migrate' to the SaveStateEntry and tests for it in vmstate_save. This would >> replace anything that touches memory. >> >> Cam >> >> --- >> hw/hw.h | 1 + >> savevm.c | 32 +++++++++++++++++++++++++++++--- >> 2 files changed, 30 insertions(+), 3 deletions(-) >> >> diff --git a/hw/hw.h b/hw/hw.h >> index d78d814..7c93f08 100644 >> --- a/hw/hw.h >> +++ b/hw/hw.h >> @@ -263,6 +263,7 @@ int register_savevm_live(const char *idstr, >> void *opaque); >> >> void unregister_savevm(const char *idstr, void *opaque); >> +void mark_no_migrate(const char *idstr, void *opaque); >> > > I'm not thrilled with the name but the functionality is spot on. I > lack the creativity to offer a better name suggestion :-) Tongue firmly in cheek: mark_sedentary()? -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html