On Tue, 2024-12-03 at 10:20 +0800, Binbin Wu wrote: > > +/* > > + * The TDX module exposes a CLFLUSH_BEFORE_ALLOC bit to specify whether > > + * a CLFLUSH of pages is required before handing them to the TDX module. > > + * Be conservative and make the code simpler by doing the CLFLUSH > > + * unconditionally. > > + */ > > +static void tdx_clflush_page(struct page *tdr) > The argument should have a generic name instead of tdr, because it's not > limited to TDR. Doh, yes. Thanks.