> > diff --git a/arch/x86/kvm/svm/sev.c b/arch/x86/kvm/svm/sev.c > > index cea41b8cdabe4..d7cef84750b33 100644 > > --- a/arch/x86/kvm/svm/sev.c > > +++ b/arch/x86/kvm/svm/sev.c > > @@ -89,7 +89,7 @@ static unsigned int nr_asids; > > static unsigned long *sev_asid_bitmap; > > static unsigned long *sev_reclaim_asid_bitmap; > > > > -static int snp_decommission_context(struct kvm *kvm); > > +static int kvm_decommission_snp_context(struct kvm *kvm); > > Why the name change? It seems like it just makes the patch a bit harder > to follow since there are two things going on. > KVM and ccp both seem to like to name their functions starting with sev_ or snp_, and it's particularly hard to determine provenance. snp_decommision_context and sev_snp_guest_decommission... which is from where? It's weird to me. > Thanks, > Tom > -- -Dionna Glaze, PhD, CISSP, CCSP (she/her)