Re: [PATCH v3 1/9] iommu: Pass old domain to set_dev_pasid op

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2024/10/18 13:53, Yi Liu wrote:
To support domain replacement for pasid, the underlying iommu driver needs
to know the old domain hence be able to clean up the existing attachment.
It would be much convenient for iommu layer to pass down the old domain.
Otherwise, iommu drivers would need to track domain for pasids by themselves,
this would duplicate code among the iommu drivers. Or iommu drivers would
rely group->pasid_array to get domain, which may not always the correct
one.

Suggested-by: Jason Gunthorpe<jgg@xxxxxxxxxx>
Reviewed-by: Jason Gunthorpe<jgg@xxxxxxxxxx>
Reviewed-by: Kevin Tian<kevin.tian@xxxxxxxxx>
Signed-off-by: Yi Liu<yi.l.liu@xxxxxxxxx>
---
  drivers/iommu/amd/amd_iommu.h                   | 3 ++-
  drivers/iommu/amd/pasid.c                       | 3 ++-
  drivers/iommu/arm/arm-smmu-v3/arm-smmu-v3-sva.c | 3 ++-
  drivers/iommu/intel/iommu.c                     | 6 ++++--
  drivers/iommu/intel/svm.c                       | 3 ++-
  drivers/iommu/iommu.c                           | 3 ++-
  include/linux/iommu.h                           | 2 +-
  7 files changed, 15 insertions(+), 8 deletions(-)

Reviewed-by: Lu Baolu <baolu.lu@xxxxxxxxxxxxxxx>

Thanks,
baolu




[Index of Archives]     [KVM ARM]     [KVM ia64]     [KVM ppc]     [Virtualization Tools]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Questions]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux